Resolver Status Display Issue in Portal (No Impact on DNS Services)

Minor incident EU-01 Log processing
2024-09-12 21:00 CEST · 3 days, 13 hours, 54 minutes

Updates

Resolved

Summary

We are pleased to inform you that the issue affecting the display of resolver statuses, DNS traffic data, and threats data in our Admin portal has been resolved. As of 12:00 AM UTC on Sunday, all logging services have been fully restored.

What Happened

From September 13 to September 15, an internal system issue affected our backend processes, leading to:

  • Inaccurate Resolver Statuses: Resolvers were incorrectly displayed as “unavailable” or “connected” (instead of “Active”).
  • Missing DNS Traffic and Threats Data: Charts and logs did not display recent data or appeared incomplete.

Data Logging Impact

  • Missing Data: Due to the system issue, there may be gaps in DNS traffic and threats data in the Admin portal for the period between September 13 and September 15.
  • Data Recovery Efforts: Our engineering team has assessed the situation, and unfortunately, some of the missing data may not be recoverable.
  • From what we are able to recover, it will be restored by today at 12:00 PM UTC.
  • We sincerely apologize for any inconvenience this may cause.

We apologize for any inconvenience this incident may have caused and appreciate your understanding.

If you have any questions or require further assistance, please contact our support team via Freshdesk.

September 16, 2024 · 10:31 CEST
Update

We would like to provide an update to the ongoing incident regarding portal display issues. In addition to the previously mentioned inaccurate resolver statuses, we have identified that DNS traffic data and Threats data are currently not visible in the admin portal. We apologize for not including this information in our initial incident report.

September 13, 2024 · 13:14 CEST
Issue

We are currently experiencing an issue where the resolver statuses displayed in our Admin portal may not accurately reflect their real-time state. You might see your resolvers incorrectly marked as “connected” or “unavailable”. This discrepancy is due to an internal system issue affecting our backend processes responsible for updating resolver statuses in the Admin portal. Please rest assured, this is solely a display issue; your DNS resolution services are operating normally and are not affected by this issue.

What You May See:

  • Inaccurate Resolver Statuses: Your resolvers may be displayed as “connected” when they are actually disconnected, or “unavailable” when they are operational.

Actual Status:

  • DNS Services Operational: All DNS queries are being processed normally, and resolver functionality is unaffected.

Current Status:

  • Our engineering team is actively investigating the issue to identify the root cause and implement a solution.
  • We are working diligently to restore accurate status displays in the Admin portal as soon as possible.

Next Steps:

  • Issue Resolution: Continue working on resolving the backend issue affecting status updates.

We apologize for any confusion this may have caused and appreciate your patience as we work to resolve the issue. Your DNS services continue to operate smoothly, and we are committed to restoring full functionality to the Admin portal promptly.

If you have any questions or need assistance, please contact our support team.

September 13, 2024 · 10:30 CEST

← Back