Resolvers page loads slowly / fails to load
Minor incident
EU-01
Admin Portal
2026-01-05 11:00 CET
· 3 hours, 59 minutes
Updates
Resolved
January 5, 2026 · 14:58 CET
The issue is resolved. The Admin Portal → Resolvers page should now load normally.
We’re working on preventative measures to reduce the risk of recurrence.
Issue
January 5, 2026 · 12:23 CET
We’re investigating an issue in EU-01 where the Admin Portal → Resolvers list may load very slowly or fail to load.
← Back
Services status page