DNS4EU Milan: incorrect DNS responses for some .org domains

Minor incident DNS4EU DNS4EU Public resolvers
2026-02-21 11:24 CET · 13 hours, 1 minute

Updates

Investigating

We are preparing to return the Milan DNS4EU resolver node back into service.
The node has been checked in isolation and the incorrect .org resolution observed earlier is no longer occurring — DNS queries are resolving correctly now.
As a precaution, we have added additional monitoring and alerts so we can quickly detect and respond if the issue happens again.
Our investigation is ongoing.
Next update will be shared once we have identified the root cause or have more information to share.

February 21, 2026 · 13:25 CET
Investigating

Mitigation remains in place (Milan node out of rotation). Service operating normally via remaining resolvers. Investigation into duration/scope/root cause continues. Next update in 60 minutes (or sooner).

February 21, 2026 · 12:04 CET
Issue

We are investigating an issue affecting the DNS4EU public resolver in Milan where some .org domain queries may have returned incorrect DNS responses.
As a mitigation, we have removed the affected node from service.
We are analyzing logs to determine scope and root cause. Next update in 30 minutes (or sooner).

February 21, 2026 · 11:24 CET

← Back