Slow performance of several services
Minor incident
Main region
Admin Portal
API
Retail services
2026-04-01 08:20 CEST
· 3 hours, 40 minutes
Updates
Issue
April 1, 2026 · 11:50 CEST
We are experiencing performance issues affecting some services, such as the Admin portal, the End Customer portal, and others. Users may encounter slow loading times on the resolvers page, errors during domain analysis, and statistics may fail to load.
Update: Systems resumed normal operations
← Back
Services status page