Management API service degradation

Major incident Main region Retail services
2026-04-07 14:05 CEST · 2 hours, 31 minutes

Updates

Resolved

The Management API has fully recovered and service is operating normally for all customers. After continued monitoring, we have confirmed stability and are now closing this incident.

April 7, 2026 · 18:06 CEST
Update

The Management API is recovering and service is gradually returning. We are continuing to monitor the situation closely to ensure stability before closing the incident. Some customers may still experience intermittent issues during recovery.

For more details on recovery you can follow our infrastructure provider updates https://exoscalestatus.com/incidents/230257

April 7, 2026 · 16:36 CEST
Issue

We are currently investigating service degradation affecting the Management API.
Our team is actively working to identify the cause and restore full service as quickly as possible.

Based on our current investigation, this issue is connected to degraded performance reported by our infrastructure provider.
https://exoscalestatus.com/incidents/230257

We will share the next update as soon as we have more confirmed information.

April 7, 2026 · 14:51 CEST

← Back