Resolver dashboard data missing in Admin Portal

Minor incident Main region Admin Portal
2026-04-21 16:15 CEST · 52 minutes

Updates

Resolved

The issue affecting the Resolvers metrics dashboard in the Admin Portal has been resolved. Metrics ingestion is operating normally again and missing data has been backfilled.

DNS resolution and protection were not affected during this incident; the impact was limited to dashboard visibility only.

April 21, 2026 · 17:39 CEST
Update

We have identified the issue affecting the Resolvers metrics dashboard in the Admin Portal and applied mitigation. Resolver metrics are now flowing again and missing data is being backfilled.

DNS resolution and protection were not affected during this incident; the impact was limited to dashboard visibility. We are monitoring the situation to confirm full recovery before resolving the incident.

April 21, 2026 · 17:07 CEST
Issue

We are investigating an issue affecting the Resolvers metrics dashboard in the Admin Portal. Some customers may currently see missing metrics for the last few hours.

The issue appears to be related to delayed or missing data in the resolver metrics pipeline. DNS resolution and protection remain operational; this issue affects dashboard visibility only.

We will share another update as soon as more information is available.

April 21, 2026 · 16:15 CEST

← Back